0
$\begingroup$

I am very new to blender and might be asking a very silly question,

I am using blender 2.8 ..in shading workspace or in lookdev mode all the objects appear black..but when rendered it appears fine. See attached image for reference. Please help.

Thanks in advance.enter image description here

$\endgroup$
1
$\begingroup$

The Shading_View_Problem.blend file that you uploaded is not showing the problem for me.

The only way I can reproduce what you have is if I enable the Scene World lighting in the Shading drop down menu then in the Shader Editor I switch from Object to World and then disconnect the Background node from the Worlds Output node. This sometimes results in what you are experiencing but not always. The 3D view remains with the Black cube etc until I move the cursor back to the 3d Editor again, then the scene seems to update and turn the whole view black.

enter image description here

I have no idea if this is a bug or something to do with the graphics card (mine is a 1080 ti with updated drivers) or something else completely.

All I can suggest is that you download 2.80 again, sorry.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi 3fingerdfrog, thanks a lot for your support...I too think that it may be due to graphics card..mine it too old...I would work on your suggestion to download a newer version of blender 2.8 also..thanks again... $\endgroup$ – Abhishek Buddhawar Feb 15 '19 at 18:23
0
$\begingroup$

Something you could try:

Top right of the 3D Editor window, open the Shading drop down and make sure that you have the Scene World lighting option unchecked.

enter image description here

Edited, Below is Abhisek's updated screenshot showing his Shader drop down menu.

View after update

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.