0
$\begingroup$

I'm trying to texture a mesh and I manage to have it looking fine in texture paint:

enter image description here

But then when I switch to any other viewport that isn't texture paint it looks super blurry, like this:

enter image description here

It's worth nothing that when I import it to Unreal it looks like the second, blurry version.

Can somebody tell me what I'm doing wrong please? I've tried looking at similar issues from other people but I haven't had luck with the suggestions in those (smooth shading, recreate the materials, change resolutions...)

Thanks :)

$\endgroup$
  • $\begingroup$ What does the image look like in the 2d image editor? Is it blurry there as well, or finely detailed as you expect? Is there a setting on your texture that uses mipmap/ Gaussian blur or something like that in the game engine? In Blender, is your scene set to simplify textures? Maybe show a screen from blender on these settings if you can. $\endgroup$ – Craig D Jones Feb 13 at 13:50
  • $\begingroup$ Do you mind sharing the file? It's hard to reproduce this issue. $\endgroup$ – Jackdaw Feb 13 at 19:32
  • 1
    $\begingroup$ Hey guys, I found the issue. My UV was wrong (I automated it), when I made it manually the problem went away. Why it appeared ok in texture paint but not in the final render I don't get though, but anyways it's solved. Thank you very much for your attention though :) $\endgroup$ – Infprent Feb 13 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.