0
$\begingroup$

I have tried over and over to get snapping faces to work. Occasionally it works and I have no idea why. But it seems the main problem is that it always wants to snap to the MIDDLE of an object. Even if I try and move the 3D cursor to the bottom.

I have set the snapping to face, active, align to rotation and snap to individual elements. I am using the control key to snap.

As you can see in the screen recording, when I snap, the cylinder pops into the middle of the box, which is no good. Nothing I seem to do helps. I also wonder if there is a way to snap faces while in edit mode, which would be super helpful.

enter image description here

https://www.youtube.com/watch?v=SHTabuakfdE&feature=youtu.be

$\endgroup$
  • $\begingroup$ The origin on both objects (from and to) is set to geometry. If you are asking did I click the 3D cursor to (either) object, yes I have tried that on both faces, same result as in the movie. $\endgroup$ – MajorTom Feb 12 at 20:00
  • $\begingroup$ Still does the same thing. Here's a blend file with just the two objects. Does it this file as well. dropbox.com/s/37g7uz4jt7preei/faces.blend?dl=0 $\endgroup$ – MajorTom Feb 12 at 20:29
  • 1
    $\begingroup$ if you deactivate the Project Individual Elements option, it works fine. Also, I was talking about the origin of the object that is supposed to snap, if you activate Active option you need to put it on the face you want to snap. $\endgroup$ – moonboots Feb 12 at 20:33
2
$\begingroup$

It should work if you put the Snap Target on "closest", grab("g") the object and move your cursor to the face you want to snap to.

This works the same way in Edit-Mode.

enter image description here

$\endgroup$
  • $\begingroup$ That is what I have been trying to do. It doesn't work. (Note, I am using the CTRL key to trigger snapping). See video below. youtu.be/O_wvBKwzkjc $\endgroup$ – MajorTom Feb 12 at 20:53
  • $\begingroup$ deactivate the Project Individual Elements option $\endgroup$ – moonboots Feb 12 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.