1
$\begingroup$

I just started learning Blender, so I'm following the donuts tutorial from Blender Guru. Unfortunately, I'm stuck at part 7 on rendering Sprinkles.

My problem is, the Sprinkles is visible in my viewport :

Sprinkles visible in viewport

However, when I render it, the sprinkles are gone :

enter image description here

My Blender file can be downloaded here.

Any help is appreciated. Thank you.

$\endgroup$
3
$\begingroup$

I think you need to click the camera icon next to the Sprinkle collection for it to show up in your render

$\endgroup$
1
$\begingroup$

Apparently this is the issue from older version of Blender 2.8 and has been fixed on the latest update (at least when I tested on commit d3870471, 2019-02-12).

$\endgroup$
0
$\begingroup$

Still the same behaviour in the build released today (2019-3-14), but there is a solution. I see you've created a collection for the sprinkles to act as a group in the particle emitter. That collection needs to be set to Renderable (the camera icon) to work in the particle renderer. However, if you put that one INSIDE another collection (I made one called 'Sprinkles Vis') and turn the camera icon off for that one instead, ONLY the particle system ones end up rendering.

Settings: Blender collection render settings

Render: Render result

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.