0
$\begingroup$

I'm trying to get a graphics card working with Blender that is Cycles compatible. I started with a Radeon 7000 series, that ran Blender fine, but froze the system as soon as I tried to do anything with Cycles rendering. Turns out the card was too old for Cycles.

So I borrowed another newer card, an Nvidia GTX 760 and installed it in the computer, and it works fine for the desktop and for other programs, but when I open Blender, all of the menus and text are missing. (A few weird glyphs appear as you scroll over the invisible menu options). See attached image.

I tried with both the nvidia-384 (proprietary) and xserver-xorg-video-nouveau (open-source) drivers. Same result.

I don;t know what to do. Is this a bug to report, a bad driver, should I be trying to update a library like Open GL? Blender ran fine (minus Cycles freezing issues) with the old card on this exact same machine.

This is Blender 2.8 Beta on Linux Mint 18.1.

According to Nvidia, GTX 760 can support OpenGL up to version 4.6, which exceeds the 3.3 requirement.

Is this a bug or is there something I can do to get this working?

UPDATE: just tried changing driver to the latest nvidia-415 via the package manager (sudo add-apt-repository ppa:graphics-drivers/ppa / sudo apt install nvidia-415) and the problem persists.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.