2
$\begingroup$

youtube -blender gyroid I followed this tutorial and try to do grid fill, but I stuck at "1:48" grid fill step.

-

this is how I do grid fill

I also try to change the offset but I still can't get the perfect grid fill this is after I try offset, still grid fill the wrong way

Hope someone can tell me how to fix it, thanks!

this is the result from the video. enter image description here


2019/2/9 . update

thank you all help me to solve this problem, however , I still can't fix it by Offset or Span (press Y it works ,but it will split the model)

I opened a new file and do the same thing again this morning , then it works fine.(I use the same step) but open the old file do the same thing again ,still failed, so ,I guess it is a bug?

the new file:

$\endgroup$
1
  • $\begingroup$ Probably Grid Fill is confused with skewed and almost overlapping edge loops. Try to change the Span in operator settings. In the video it's set to 6 $\endgroup$
    – Mr Zak
    Feb 8, 2019 at 21:16

2 Answers 2

3
$\begingroup$

It appears that Grid Fill takes into account the active vertex when determining how to fill the loop. If you select a corner vertex last (or deselect and re-select one) Grid Fill should behave nicely.

You can also achieve the same result with the Span and Offset settings. Span tells Blender how many columns there should be in the filled grid. In your case there is 6 (you can tell by counting the edges on one side). The offset will tell Blender how to connect the edges. This option depends directly on the active vertex when you did the fill. Count the number of edges between the active vertex, and set the offset to that.

$\endgroup$
0
$\begingroup$

Changing only Span doesn't help me somehow (v2.79b). But if you disconnect those edges with Y key and then Grid Fill with 6 Span it works.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .