0
$\begingroup$

I'm using Blender 2.79b to make some Blender remakes, and I've started having this problem where every time I click off the window, and then click back on it again, it always closes on me with no given reason whatsoever.

I've checked the Task Manager, including some stuff on the File Explorer, and got NOTHING!!!

Does anybody happen to know what's causing this problem or how to solve it? It would really help me if you do.

P.S. I will point this out right now. Blender will only stay open if I never close off of it.

$\endgroup$
  • $\begingroup$ Do you have problem only when the objects in Blender are too complex or it happens also in newly opened Blender? $\endgroup$ – Yash Feb 8 at 13:56
  • 1
    $\begingroup$ Open and command window and run Blender.exe from there, when Blender crashes any error messages will be listed there. $\endgroup$ – rob Feb 8 at 13:59
  • $\begingroup$ As @rob said, copy that errors and edit your question adding the error lines. $\endgroup$ – Yash Feb 8 at 14:27
  • $\begingroup$ @rob There are never any error messages when it closes on itself. $\endgroup$ – THXFan2889 Feb 8 at 23:29
  • $\begingroup$ @rob Ok. I've opened it via the command prompt, and when it closed on itself, it gave me "Error: EXCEPTION_ACCESS_VIOLATION". Do you happen to know what that means? $\endgroup$ – THXFan2889 Feb 8 at 23:40
2
$\begingroup$

Don't worry guys. I figured out the reason behind the problem and fixed it.

The story behind it:

One day, I went looking for new art software (because I've been using Inkscape a lot; i still do, honestly), and I came across Medibang. When I installed it, it didn't look all that interesting to me, so I uninstalled it immediately. In the middle of that, though, came a message that said whether or not I wanted to get rid of "MdpThumb64.dll", and if I chose "No", it would cause no harm. So I clicked "No" on that message and went on with my day.

After that, every other time I went to get on the computer, it would always take a while to load up everything , and I was thinking that the .dll file was the problem, so I deleted it and then felt instant regret doing that. I then went to a DLL-downloading website, and downloaded the .dll from there. I never should've trusted them, because that's when the chaos finally ensued.

I went to Blender, clicked off and on the window again, and it closed itself (which was the main problem here). I could only assume the fake .dll file was behind all this, so I did a System Restore (in which the restore point was all the way back in January of 2019), tried the click-on-and-off thing again, and nothing happened. It never closed on itself after that, therefore I finally solved the problem.

I guess it turns out that there was no "MdpThumb" DLL file on Windows to begin with. (hehe)

$\endgroup$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.