2
$\begingroup$

I have an idle animation for a character. I made sure, that the start frame (0) and end frame (60) are the same, so it can smoothly loop.

But for some reason the animation just stops at the end for a short time and starts from a new:

enter image description here

Here the graph of the rotation animation (It eases in and out on the start and end frame): enter image description here

Am I missing something?

Thanks in avdance!

$\endgroup$
  • $\begingroup$ Blender file: mediafire.com/file/hlvsppll15g4xbn/PlayerTest.blend/file $\endgroup$ – Funcestor Feb 8 at 11:01
  • $\begingroup$ Your animation looks like when the head in comming downwards in the end is probably not similar to the start! $\endgroup$ – Yash Feb 8 at 11:03
  • 1
    $\begingroup$ try animating 59 frames. Imagine you had a 3 frame animation where frame 1 was the head UP, frame 2 was the head DOWN and frame 3 was the head UP in the same location as frame 1. If you now play that animation in a loop you get UP,DOWN,UP,UP,DOWN,UP,UP ... you want to avoid those double UPs. $\endgroup$ – rob Feb 8 at 11:07
1
$\begingroup$

As Rob said, you should stop your loop at frame 59 so that the same pose is not repeated twice, but you should also copy your frame 15 pose and paste it at 45, because as you see it's not the same right now, so from frame 30 to 60 the movement is very slow and it may participate to what annoys you.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.