7
$\begingroup$

I'm working in the new 2.8 with someone else's file (made in a previous version of Blender), and I can't get the textures showing in the viewport. I've relinked all of them to the correct location on my computer and Blender can seem to find them, but just won't display them in the viewport. I've made sure I'm in LookDev mode, and also added a lamp, but still nothing. enter image description here In 2.79, it was always just a matter of finding missing files and that's it... Can anyone see what I'm doing wrong here?

Thanks!

$\endgroup$
  • $\begingroup$ Maybe your version of 2.8 has a bug but I don't know why you'd go to lookdev mode to see your texture: just stay in solid mode and set your viewport to textured and tell us if you still have this problem $\endgroup$ – AnthoJack Feb 7 at 9:22
  • $\begingroup$ Not sure what you mean... Version 2.8 doesn't have a textured viewport option, as far as I know. According to other threads here, it's been replaced by Lookdev mode. $\endgroup$ – 4mylgl6 Feb 7 at 10:16
  • $\begingroup$ at the bottom right of your screen shot, at the left of "Shading", you have 4 buttons which correspond (from left to right) to your "Wireframe", "Solid", "Textured" and "Shaded" views. to see your textures you usually just have to select "Solid" in the pie menu appearing when you press "Z" and click on the "Textured" button. no use to be in LookDev mode $\endgroup$ – AnthoJack Feb 7 at 10:31
  • 1
    $\begingroup$ What you're referring to as "Textured" seems to have been replaced by the term "Lookdev". As you can see in the two screenshots here, the buttons you mentioned both in the bottom row and in the pie menu are called "Lookdev" in v2.8 (see tooltip). imgur.com/a/LVbqn6u imgur.com/a/91DUGEj In any case, pressing them to activate this mode, however you call it, doesn't make the textures show up. $\endgroup$ – 4mylgl6 Feb 7 at 12:04
  • $\begingroup$ You've got the point light selected in the screenshot. If you select the body mesh is the texture updated or even applied there? You may have to recreate the material as well depending in the render engine used. $\endgroup$ – Brenticus Feb 7 at 14:55
3
$\begingroup$

Blender 2.8 uses an entirely different materials system from previous versions. As a consequence of this (and perhaps also as a result of some missing backwards compatibility features in Blender 2.8), image-based materials created in older versions of blender get replaced with plain, solid-color materials with no textures when opened in Blender 2.8.

To fix this, you will need to manually re-assign textures to their appropriate materials in the project. Select the model you want to fix, then in the properties editor go to the materials tab, select a material to fix, and click "Use Nodes". Next, click the small button to the right of the "Base Color", and click "Image Texture". Finally, click the image dropdown below the base color, and select the correct texture for the material you have selected. Depending on how well named the materials and textures are, you may have to use a bit of trial and error to figure out which texture goes where. Now repeat this process for every material in the project.

Yes, this could be extremely tedious depending on the size of your project, but until Blender introduces a built-in way to convert old models to the new materials system this is what we're stuck with, apparently.

For more information on this issue, see Opening old .blend files (missing images) on KatsBits.

$\endgroup$
  • $\begingroup$ Brilliant. Solved my problem. Thank you very much! $\endgroup$ – Tom Pace Oct 9 at 10:51
  • $\begingroup$ This should be marked as the answer. $\endgroup$ – Tom Pace Oct 9 at 10:52
0
$\begingroup$

The texture might be tiled.

To change:

1. Go to PROPERTIES PANEL --> "Active Tool & Workspace Settings" (the screwdriver & wrench) Blender 2.8 Active Tool & Workspace Settings


2. Find the TEXTURE TAB --> Change MAPPING from "TILED" to "STENCIL"

Change Mapping from Tiled to Stencil in Blender 2.8


After this change, my texture was visible in viewport: Texture Showing In Viewport, Blender 2.8

I ran into a similar problem doing a Blender 2.8 sword tutorial on youtube. Answer credit goes to the comment section of that tutorial: Answer to this page's question

$\endgroup$
0
$\begingroup$

The real problem is Blender gurus didn't default the view to show textures in edit mode if that's where you edit the textures. If you think you are setup correctly simply Press Z then choose Look Dev. Your texture should show up. You can also switch to texture paint and texture will show up but it's kind of silly you cannot use the UV editor which would actually make more sense since it is texture paint mode. Poor thought in this aspect.. If I am in the UV editor Blender should default to showing Look Dev not stay in solid rendered or wire framed. If I am in Texture Paint mode it should allow changes in UV mode because that is part of texture painting not modeling.

New contributor
Calvin Lynch is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.