8
$\begingroup$

just trying to use shadeless lighting for a material, but cant find where it is in 2.8 This is how it looked in the older versions:

enter image description here

Any help is appreciated, thank you!

$\endgroup$
1
  • $\begingroup$ Just plug some color/texture directly to the Material Output surface input. $\endgroup$
    – Kvakor
    Apr 22, 2020 at 11:19

7 Answers 7

9
$\begingroup$

The option shown there is for Blender Internal renderer, which has been removed in Blender 2.8. See the following questions for information on how to create a shadeless material using the shader node graph.

Totally white shadeless material in Cycles?

Node for setting render colour, regardless of lighting

These setups will work for both Cycles and EEVEE in Blender 2.8

$\endgroup$
1
  • 3
    $\begingroup$ Hi. This is currently a link-only answer. If the other questions disappear, then this answer no longer provides information. Please include at least some of the actual techniques mentioned in those answers in the body of your answer. Thanks. $\endgroup$ Jul 10, 2020 at 12:17
5
$\begingroup$

For those wanting to turn off shading in a script in python, the old:

bpy.context.object.active_material.use_shadeless = True

is now in Blender 2.8x:

bpy.context.object.active_material.shadow_method = 'NONE'
$\endgroup$
0
2
$\begingroup$

enter image description here

You have that option while importing the plane. Press N to make the options visible or use the gear icon on the top right of the window

Change the Material from Principled to Shadeless.

$\endgroup$
2
$\begingroup$

In Blender 3+, if you just plug the Color straight to your material output Surface, you get unshaded data.

$\endgroup$
1
  • $\begingroup$ Seems to work. I plugged a color ramp node's output to the surface input of the Material output node. $\endgroup$
    – user44109
    May 31, 2023 at 23:41
1
$\begingroup$

Just set the surface to "Emission", and strength to 1, seems to work.

enter image description here

$\endgroup$
2
  • 5
    $\begingroup$ bad idea, because then it emits light. $\endgroup$
    – stackers
    Jan 2, 2020 at 23:05
  • 1
    $\begingroup$ It doesn't work when the image has some transparent alpha parts, those are set to black. $\endgroup$
    – Sandra
    Jan 19, 2020 at 10:14
1
$\begingroup$

There is no need to mess with nodes or read over multiple FAQ.

What you're looking for is the, "Flat" Lighting Method in the "Solid" Viewport Shading options.

In the image below I have the 'Color Type' set to 'Texture' to preview my Baked out AO without any additional Shading or Lighting.

Flat Viewport Shading (Shadeless)

To render wwitch to Workbench render engine.

$\endgroup$
3
  • 7
    $\begingroup$ This only affects the viewport and isn't comparable to the blender render "shadeless" material option. $\endgroup$
    – bstnhnsl
    Nov 5, 2019 at 15:39
  • 1
    $\begingroup$ @bstnhnsl No - you can render it with Workbench engine , and yes - it is not comparable with 2.79, but in a meaning of possibilities combine other materials. $\endgroup$
    – vklidu
    Jul 19, 2020 at 7:17
  • $\begingroup$ I love this technics but it is really hard to work with it with photogrammetry asset as you can't model on top of it, every other mesh will also be flat, making it worthless. $\endgroup$ Nov 14, 2022 at 12:54
1
$\begingroup$

Import Image As Plane Addons seems to show the right way using nodes:

enter image description here

Simply use a Mix Shader with IAP_SHADELESS

$\endgroup$
1
  • $\begingroup$ This seems to work better than the other options, but keep in mind IAP_SHADELESS is only added when you use this add on $\endgroup$
    – stackers
    Nov 15, 2021 at 3:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .