0
$\begingroup$

In the first image, I'm using Eevee with an environment texture -- the star field background is clearly visible. But, if I change nothing but the rendering engine (to Cycles), the environment disappears.

This is 2.80 beta (2019-01-07). I get the same result on Windows and Mac, with multiple recent 2.8 beta builds.

Using Eevee, env texture is rendered

Using Cycles, no luck!

$\endgroup$

1 Answer 1

2
$\begingroup$

I found my own answer with endless setting-tweaking: in the Render settings, the Film > Transparency checkbox was selected. The tooltip says "World background is transparent, for compositing render over another background."

Serves me right for being a beginner.

$\endgroup$
1
  • $\begingroup$ A reminder to all: Use Nodes must be enabled for the World material, regardless of which render engine is being used. $\endgroup$
    – Mentalist
    Sep 1, 2020 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .