0
$\begingroup$

I'm having sort of a weird problem. I've made a model of a building in Blender. It is not rigged, there is no armature whatsoever. But when I import it as an FBX into Unity, it imports it as though it were! And because of this, Unity is doing crazy things like deleting intersecting polygons, taking entire walls out of my building in the process. Is there something in the FBX export settings that is causing it to import as a rigged model? Is there something I can do in Unity to tell it to stop deleting my polygons? Why is this happening?

rig1 rig2

$\endgroup$
2
$\begingroup$

That is just how Unity reads .fbx files, because they can have rigs in them.

It doesn't mean your building is rigged though.

Go to the rig tab, and make sure it's set to either none or generic (I can't remember fully the options, I do not have Unity to hand to check)

Unity doesn't have the ability to edit raw geometry as far as I know, so it wouldn't be deleting polygons. This is probably an issue with normals, check your normals in blender, and make sure whatever shader you're using is double sided, ie no backface culling and that should clear up your issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.