2
$\begingroup$

I am continuously trying to install FSPY, but according to the instructions on the Github, it is clearly mentioned that not to unzip it.

enter image description here
I tried it to import it as File>Import>fspy, but there is no option for FSPY... I also tried to install the zip file from Blender(Install Addon) enter image description here

Then how can I install it?
Any advice will be really appreciated!

$\endgroup$
0

6 Answers 6

7
$\begingroup$

TLDR; Download the latest release: https://github.com/stuffmatic/fSpy-Blender/releases


Scroll down the github page and read the instructions on how to install the add-on properly:

  1. Download the latest version from the release page (fSpy-Blender-VersionNumber.zip)
  2. In Blender go to Edit > User Preferences > Add-ons and click Install from File
  3. Select the fSpy-Blender-VersionNumber.zip file by using the file browser
  4. Don't forget to enable the Add-on

If successfully enabled, a new menu entry in File > Import will appear:

enter image description here


Don't download the entire repository!

enter image description here

Again, download the latest release: https://github.com/stuffmatic/fSpy-Blender/releases

$\endgroup$
2
  • 1
    $\begingroup$ Apologies for confusion re screenshot comment. Suggest in future posting the link to the addon source in question. IMO no need for screenshot proof of missing menu item. If your question is in regards to 2.8 or prior, for the time being might pay to flag in title. $\endgroup$
    – batFINGER
    Feb 2, 2019 at 8:16
  • $\begingroup$ Apologies my side too..✌ $\endgroup$
    – Yash
    Feb 2, 2019 at 8:32
2
$\begingroup$

You need to install the addon first.

For 2.79 Go to File > User Preferences > Add-ons and click the button in my screenshot and point the dialog box to the .zip file

enter image description here

For 2.8 Go to Edit > Preferences > Add-ons and click the same button and point the dialog box to the .zip file

enter image description here

EDIT: Then make sure the addon is enabled like so:

enter image description here

Then you can go to File > Import and you should be able to import your desired file type.

$\endgroup$
9
  • $\begingroup$ I didn't understand that how to point the dialog box to the zip file $\endgroup$
    – Yash
    Feb 1, 2019 at 15:53
  • $\begingroup$ Once you click "Install Addon from File" you will be able to navigate you your .zip file, once you do that the add-on will be installed. $\endgroup$
    – Facity
    Feb 1, 2019 at 15:56
  • $\begingroup$ I already did that, then to add-on is not showing in the list.. $\endgroup$
    – Yash
    Feb 1, 2019 at 15:57
  • $\begingroup$ Apologies, I for some reason assumed you had installed addons before, so missed a step. I have edited my answer for you. $\endgroup$
    – Facity
    Feb 1, 2019 at 16:00
  • $\begingroup$ No you are getting it wrong, I had installed add-on previously like BLAM, it installed without any problems and it was by this method only to install it from blender itself but this(fspy) isn't installling, it may be installing but is not showing in the list to enable it.. $\endgroup$
    – Yash
    Feb 1, 2019 at 16:06
2
$\begingroup$
  1. Download and Install FSpy Application for windows. (https://github.com/stuffmatic/fSpy/releases/download/v1.0.3/fspy-setup-1.0.3.exe)

  2. Download FSpy Add-on for Blender. (https://github.com/stuffmatic/fSpy-Blender/releases/download/v1.0.2/fSpy-Blender-1.0.2.zip)

  3. Open Blender > Preferences > Add-ons > Install Add-on > Select the downloaded 'FSpy-Blender-1.0.2.zip'

  4. Enable the add-on

  5. Open the FSpy Windows client and Open a reference image. (tweak the perspective as necessary)

  6. Save the "tweaked" image as .fspy"

  7. Import the .fspy image and you're good to go

$\endgroup$
1
$\begingroup$

I think that some of the confusion with installing the FSPY in Blender 2.8 is that at least for Safari users, the downloaded zipped files automatically get unzipped if they are deemed safe in Safari by default. You will need to turn that functionality off. Go to Safari Preferences > General > and uncheck Open "Safe Files" after download. Blender is looking for the unzipped file.

I did this, then downloaded the file, and it installed in Blender 2.8 no problem. Hope this helps.

-Todd

$\endgroup$
1
  • 3
    $\begingroup$ Actually, I hope that no one is using safari anymore :P $\endgroup$
    – brockmann
    Feb 18, 2019 at 13:57
1
$\begingroup$

if you want to run fspy on LINUX you need to download this link https://github.com/stuffmatic/fSpy/releases/download/v1.0.3/fspy-1.0.3-x86_64.AppImage and then open "downloads" or folder what you select to download and click right on file named fspy.Then go to "properties" then "permisions" and click on "is executable".

I also downloaded this icon file file: https://fspy.io and click right on the logo and click "save image as" and select folder.Then click right on file named fspy.Then go to "general" then file type options and click on the icon image and browse the icon.

$\endgroup$
0
$\begingroup$

I know normally how to install addons. None of the suggestions worked. Fspy does not appear in the list, but it exists in the scripts/addon folder. Whenever the reason will be found, I would be glad to know. Maybe use an older Blenderversion just for fspy...- very professional lol! - Greeez!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .