209
$\begingroup$

I would like to render an animation as a series of .png images with transparent backgrounds for use in a video. Is this possible?

$\endgroup$
307
$\begingroup$

Yes this is possible.

To save rendered images with transparent background (PNG format for instance), the settings are as follows for "Cycles" and "Blender Render" rendering engines.

Cycles

Properties Editor > Render Context > Output Panel

Choose RGBA so that the alpha from the renderer is saved in the png

Properties Editor > Render Context > Film Panel

Check Transparent so that the World background is transparent.

Saving PNG with alpha using Cycles

Blender Render

Properties Editor > Render Context > Output Panel

Choose RGBA so that the alpha from the renderer is saved in the png

Properties Editor > Render Context > Shading Panel

Choose Transparent Alpha type.

Saving PNG with alpha using Blender Internal

EEVEE (Blender 2.8)

Properties Editor > Render Context > Film Panel

Choose Transparent Alpha type.

Saving PNG with alpha using EEVEE

$\endgroup$
  • 28
    $\begingroup$ This is the answer. $\endgroup$ – iKlsR Jun 23 '13 at 14:29
  • 5
    $\begingroup$ One year after, and yet again it helped me. $\endgroup$ – Valentin Mercier Aug 1 '14 at 19:28
  • 2
    $\begingroup$ Why does blender still spend render time with the tiles on the transparent parts? $\endgroup$ – Anson Savage Jun 17 '15 at 4:21
  • 2
    $\begingroup$ @Anson What I believe is that the camera is shooting rays into the scene and since there is no returning ray , there must be a timeout wait before the render decides to move on to the next square. $\endgroup$ – hawkenfox Jan 1 '16 at 13:31
  • 2
    $\begingroup$ I can't because the answer is a bit of a trap; PNGs can never render transparency correctly from a technical vantage. Best hope is to educate the imagers around these parts so that they can become aware of the differences in alpha format, and the impact on their work. $\endgroup$ – troy_s Jan 29 '16 at 2:31
18
$\begingroup$

In Blender Internal, If you want the background to be transparent, you can change the output type to RGBA and in the Scene tab under Layer, untick Sky.

$\endgroup$
  • $\begingroup$ Unticking "Sky" was what I needed to make it work (I already had RGBA selected). In Blender 2.79 I found this setting on the "Render Layers" context. $\endgroup$ – talljosh Sep 27 at 0:08
10
$\begingroup$

In the render settings go under Shading and set alpha to transparent. Then under output click RGBA. Unchecking Sky in the scene tab will also work but I'm not sure if that method will have an impact on any other parts of the render or if it's just a redundancy.

$\endgroup$
  • $\begingroup$ Where do you see that? I don't see any Shading section, but I do see Sampling, AO, Bloom, DoF, Subsurface Scattering, SSR, Motion Blur, Volumetrics, Hair, Shadows, Indirect Lighting, Film, Simplify, Freestyle, and Color Management. $\endgroup$ – Aaron Franke Sep 11 at 0:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.