4
$\begingroup$

I have a scene where I want to put an object with a volume renderer under glass, but I've discovered that my volumes don't seem to render when they're behind a transparent object.

enter image description here

I'm new to eevee, and relatively new to blender overall, so I don't know if this is an inherent limitation of the renderer or if there's a setting I need to change, or functionality I need to turn on.

Can I fix this?

$\endgroup$
2
  • 2
    $\begingroup$ could you provide your .blend? Or maybe a screenshot of your shadertree/material settings. For me it's working fiine, with glass, refraction and transparency shader. Alpha set to Multiply $\endgroup$ – Chris Jan 28 '19 at 11:40
  • 1
    $\begingroup$ I could post those, but your suspicion was right - I didn't change the Alpha blend mode. $\endgroup$ – jwrush Jan 28 '19 at 16:54
2
$\begingroup$

Chris pointed me in the right direction - I had the blend mode set to opaque. Changing it to multiply fixed my render.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.