1
$\begingroup$

In 2.79 with my scene units set to millimeters and Unit Scale set to 0.001 I never had a problem, now with 2.8 I need to change the scale at export to 1000 to get a correct size model after importing into software that cares about scale, namely my 3D printing slicer. From what I understand, Unit Scale in the Scene properties only changes the reporting of the units now.

I've tried all manner of combinations to get the reported units to marry up with the exported size without having to scale on export but with no luck.

Is there a way to setup the scene so that I don't have to scale at export, or is this something I just have to live with??

Thanks

$\endgroup$
  • $\begingroup$ I am having the same exact issue with 2.80 The problem is that everything I do now when sculpting is in a wrong unit internal set. So displacements, values for different brushes etc get crazy. The worst.. knife tool and bool operations do not work properly. In fact the do not work at all, even if I apply scale, position etc. Visualization is another drawback, the viewport is always producing artifacts when certain modes, for example if I turn on centra face points all the view get full of dots because I can see trough all the objetc. It is a real pain! Not to mention that to continue with my o $\endgroup$ – Jose Rozua Sep 8 at 10:22
  • $\begingroup$ @JoseRozua See my answer below $\endgroup$ – Ash yesterday
1
$\begingroup$

I just started using Blender, this drove me nuts. After messing around with Blender settings to work in cm I just reverted back to using meter. I made a cube 10 m square, exported an STL with no scaling and was able to load in a perfect 10 mm cube into simplify3D, so it seems just setting blender to metric meters and treating meters as mm will work.

$\endgroup$
  • $\begingroup$ Thanks Jeff. See my answer below. I hope it helps you too! $\endgroup$ – Ash Jun 10 at 4:02
0
$\begingroup$

I actually figured this out.

You need to set your scene to metric, use millimeters as the length, and here's the critical part, set the scene units to 0.001

This makes all the units display as millimeters and the scaling in exports correct as well. It also makes the units in things like modifiers and textures and everything else make a lot more sense, instead of having to use ridiculously small or large numbers in in something like the settings for a displacement modifiers texture. It also helps the sliders be more controllable.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.