0
$\begingroup$

I am wondering if it's possible to set up the following scenario: Initiate render -> Eevee render into render layer with specified render settings -> Switch to Cycles render engine with specified render settings (specifically just a free style pass) into a render layer -> Composite using compositor alpha over

Is this currently possible? I saw some solutions for combing Blender Internal and Cycles render passes in 2.79 but I am unsure if this kind of functionality is available in 2.8

My intention is to use this as a work around until freestyle is functional in 2.8.

Thank you

$\endgroup$
1
$\begingroup$

This solution seems to get me 99% of what I originally asked for in the question.

Okay I got it to work, my problem was I was trying to create two different View Layers - create an additional Linked Scene instead so all your objects stay consistent between the two, in compositing make two Render Layer nodes and set each one to the respective Scenes you've rendered. Then you can alpha over the scene with the Freestyle pass and the Eevee pass.

My only problem now is that if I render both the scenes (as in neither has "Use Single Layer" clicked) it takes about 2 minutes for a very simple scene, but if I render them individually (One after another with "Render Single Layer" clicked) they each respectively take a second or two. It seems that when I render them both concurrently the Cycles pass still path traces the objects even with all the passes and ray visibility disabled. Not sure if I am missing something or if this is a possible bug.

$\endgroup$
0
$\begingroup$

So I'm doing something very similar, but I haven't experimented with separate scenes and concurentl renders. I found that reducing my render samples down to 1 for cycles speed up tremendously for line-only freestyle renders in cycles.

Update: I tried your scene technique, but I haven't been able to get Eevee and Cycles to play nicely when using the Shader to RGB node.

$\endgroup$
  • $\begingroup$ The problem with that approach is that samples also controls the samples for the Freestyle itself, setting the samples to 1 results in aliased Freestyle lines $\endgroup$ – llanw Jan 26 at 2:33
  • $\begingroup$ Can you clarify what problem you're having with Shader to RGB? I am using Shader to RGB in my scene, make sure to filter out everything except Freestyle and disable all the passes in the Freestyle scene. $\endgroup$ – llanw Jan 26 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.