0
$\begingroup$

If i'm rendering on GPU, is there any way to re-render without having to rebuild the entire scene again (bvh etc).

I'm just trying to tweak render settings between re-renders so I can optimise it for the fastest possible render time per frame for an animation.

Scene build time takes 2-3 minutes, so it's getting really frustrating having to tweak the number of samples, then wait 3 minutes to see the effect, then tweak again, wait another 3 minutes, then again ...

It's like torture.

I thought persistent images might do the trick, but no, it still has to rebuild the entire scene every time...

$\endgroup$
  • 2
    $\begingroup$ Hi. Please make question titles descriptive of the problem. This will mean people who can answer it know to click on it and people who have the same problem can find also find an answer (if this gets answered). $\endgroup$ – Ray Mairlot Jan 25 at 19:42
0
$\begingroup$

You could hide the objects that are taking up unnecessary performance, to preview only the ones you want or what will give you a good preview. You can also render only a small part of the image. Here's a tutorial https://www.youtube.com/watch?v=94UsZw6mTaE

$\endgroup$
  • $\begingroup$ Thanks Rix, this really helped me find the solution. $\endgroup$ – user3597862 Jan 25 at 20:32
0
$\begingroup$

I found the solution! Partially thanks to Rix Yarbrough's youtube link above, from which I learnt that the Border option is respected in interactive viewport rendering when in camera view.

So my new workflow is:

Render without the border to find the noisiest part of the render. press ctrl + B to draw a render region on the 3d viewport tweak the materials (adding light path nodes to the bumps etc) tweak the render settings until ideal (samples, clamping, bounces, materials etc) copy tweaked preview settings to the render settings (samples etc) Render!

Huge time saver.

For me my scene had a huge number of scattered objects which the viewport couldnt handle, but I needed these included whilst tweaking the settings, so a solution was to select all of the objects that were being used to scatter, and then in the object tab of the properites panel, set maximum draw type to bounds. The particle system then respected this setting and allowed me to display all particles in the viewport, and they still rendered as full objects in the preview render.

Perfect!

Now we just need the ability to view different render passes in preview rendering to better ascertain which ray type is the noisiest. This will speed up optimising the settings even more.

Thanks Guys.

$\endgroup$
  • $\begingroup$ Make sure you mark your post as "answer" to your question by clicking on the ✓ next to it. $\endgroup$ – Amir Jan 30 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.