2
$\begingroup$

Recently while trying to render fire I run into a problem where the fire shows up in preview but it does not render, only the light that comes from it. Rendered Preview

All the settings are at default, I can't seem to find what is causing this as I was perfectly able to render fire before. enter image description here

$\endgroup$
4
$\begingroup$

I recently had a similiar problem. Your render, in fact, is correct, but the result is displayed incorrectly. This is due to the way alpha is represented in the viewer, which uses straight alpha rather than premultiplied, so emissive volumes like fire can't be properly modelled. For a detailed explanation, see this answer.

To see the fire, just try switching to RGB mode instead of RGBA in the image viewer and you'll see the flames: switch image display mode

As suggested in the linked answer, a solution would be to use an EXR image wich has premultiplied alpha. If you can't use an EXR however, you need to convert the premultiplied alpha to straight alpha in the compositor, then save as e.g. PNG: compositor setup

| improve this answer | |
$\endgroup$
  • $\begingroup$ when using the premultiplied alpha node the fire still isn't there, am I doing something wrong? $\endgroup$ – LettuceIsland Jan 25 '19 at 9:43
  • $\begingroup$ Are you using the "Premultiplied to Straight" setting? Is your render up to date (F12), and is the fire visible in the current animation frame (switch to rendered mode)? $\endgroup$ – Ignatiamus Jan 25 '19 at 10:59
  • 1
    $\begingroup$ @Ignatiamus is absolutely correct here. Unassociated (straight) alpha has no place in a compositing pipeline. The fact that Blender screws this up is part of the problem. Get rid of that convert alpha node, and spread the word about The One True Alpha. ;) $\endgroup$ – troy_s May 23 '19 at 3:15
0
$\begingroup$

I also have this problem every now and then. For me neither solutions worked, the converter nor the EXR render.

For the people that also can't do those two things. I simply rendered out an emission pass (for animation). In 2.8 that is easily done. Blender volume emission pass

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.