1
$\begingroup$

I am using blender 2.8. This is a contrived example, I am working on another project with many 'assets'.

I have created a collection called 'gizmo', grouped under 'Assets'. This is at (0,0,0) in world space. I turned off render for this collection.

Now I add some instances of gizmo in my scene, and arrange them. For these I set render on.

When I render the scene the gizmo instances are not rendered unless I turn on render for the original collection (gizmo). But I don't want to render the original because it's at 0,0,0. What I expected was for the collection instance render setting to be used rather than the asset render setting.

Is this a bug or is it intended to work this way? is there some other better way for me to achieve this?

the scene collection desired render output

$\endgroup$
5
$\begingroup$

I have managed a way to help you with this issue. Yesterday I was trying the same thing and I realized a way to not render the original collection and only the models created with a collection instance tool.

What you need to do is put all of your original “Assets” inside another collection. Then turn off the eye icon in all of them (including the bigger collection parent) and then turn off also the camera icon (for it not to appear on the render) but only in the parent collection and not on the assets themselves.

This means that blender will not render anything that is inside that collection but still if the objects inside are on it will interpret as if they were rendering so it will render the instances of that particular asset.

If it is not clear enough I will share an image :p

The prop collection is filled with my original assets and the workspace collection is filled with the instances created with the collection instance tool enter image description here

enter image description here

If its is not clear repost and i will try to explain better

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.