1
$\begingroup$

I've been experiencing loads of crashing while rendering lately, and after doing some testing I've finally isolated it to the GPU rendering. As soon as I change to that from CPU, blender goes down. This is odd, because I did a whole project (cgmastersnet Corvette course) with it on and had zero crashes. I have not updated Blender since then.

I found a thread about this on blender.org -> https://developer.blender.org/T53945

They seem to be saying it could be an issue with MacOS High Sierra (I am not running High Sierra, I am running Mojave 10.14.) This is my system:

Model Name: iMac
Model Identifier:   iMac14,2
Processor Name: Intel Core i5
Processor Speed:    3.2 GHz
Number of Processors:   1
Total Number of Cores:  4
L2 Cache (per Core):    256 KB
L3 Cache:   6 MB
Memory: 32 GB
Boot ROM Version:   IM142.0130.B00
SMC Version (system):   2.15f7
Graphics card: GeForce GT 755M

And this is my Blender

2.79 - 2017-9-11

I'm wondering if others have solved this issue. I'm confused on what might have changed (other than the project - which is far simpler than a corvette).

I tried removing any recent add-ons I have used in the past few weeks, saved prefs and restarted, but the crash still happens.

Not sure what other info I can provide, please let me know. For now seems I am stuck with CPU rendering, which is a bummer.

$\endgroup$
  • $\begingroup$ The question is off topic. It's about a bug. It seems it might be that the bug is not even in Blender but probably in the OS or graphics drivers. $\endgroup$ – Martin Z Jan 25 at 15:09
  • $\begingroup$ Possibly related: blender.stackexchange.com/q/128693/599 $\endgroup$ – gandalf3 Jan 26 at 0:28
  • $\begingroup$ Normally this sort of question would be closed as off topic/bug report, but I think this is a notable enough problem that it's best answered here. $\endgroup$ – gandalf3 Jan 26 at 0:46
3
$\begingroup$

Starting with MacOS 10.14 Mojave, Apple is discontinuing support for OpenCL and OpenGL, in favor of their Metal 2 technology. Maybe this has something to do with your problems.

$\endgroup$
2
+100
$\begingroup$

Apple has recently disabled OpenGL and OpenCL on their platform (see Mac Pro Tower - Sapphire Radeon Rx580 is really, really slow), and (though I haven't found an official statement from Apple) it appears Nvidia is blaming them for lack of CUDA support as well:

Developers using Macs with NVIDIA graphics cards are reporting that after upgrading from 10.13 to 10.14 (Mojave) they are experiencing rendering regressions and slow performance. Apple fully control drivers for Mac OS. But if Apple allows, our engineers are ready and eager to help Apple deliver great drivers for Mac OS 10.14 (Mojave).

Apple's recently released macOS 10.14 (Mojave) does not support CUDA. For CUDA developers who are on macOS 10.13, it is recommended to not upgrade to Mojave. Developers may not be able to use Xcode 10 to build GPU applications or run CUDA applications. Both macOS 10.13.6 and Xcode 9.4 support CUDA and work great with CUDA 10. NVIDIA is working with Apple to get Mojave to support CUDA.

Long story short, GPU rendering support on macOS has been poor for some time now and doesn't show much sign of improving in the immediate foreseeable future. OpenCL rendering support for macOS has already been disabled in Blender:

There was a growing payload of bugs in Cycles related on OpenCL on macOS platform, and those issues were caused by a compiler bug, which we have no control over.

. . .

In this case compiler will not get fixed since Apple decided to discontinue OpenCL on its platform.

So the decision was made to drop support of OpenCL [on macOS], keep official features of Blender stable and predictable, and focus on things we have control over.

P.S. Older Blender releases are always available. Surely, this sounds like using an ancient software without neat features. But we can't push Cycles OpenCL on macOS measurably beyond that anyway.

I'm not sure about the official status of CUDA support, but judging by Nvidia's statement quoted above, the situation doesn't sound much better.

It sucks, but right now it looks like your only options are:

  • Downgrade to a previous version of macOS and use an old version of Blender for rendering
  • Dual-boot with another operating system (such as Linux)
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.