0
$\begingroup$

In Blender, I made a model and baked the textures into a single image. It works great in Blender.

ex1

I imported my model as an .fbx into Unity, and then dragged in its image texture material.

ex2

For some reason, the image texture won't "line up" where it's supposed to go! I've watched a lot of YouTube tutorials and this is exactly what they tell us to do, so what could be the reason it's not working for me?

$\endgroup$
  • 1
    $\begingroup$ looks as if its not using uv's correctly in unity. Did you export them with your .fbx? Sometimes if the model has multiple uv-maps you also need to tell unity which one to use. $\endgroup$ – Chris Jan 21 '19 at 23:07
0
$\begingroup$

Okay, I had to outsource this to a smart person because I'm a beginner and frankly ignorant of all this stuff... but I'm going to post the answer for future newbies like me!

Okay, so the problem was in Blender. Inside the Object Data > UV Maps panel, I had several UV maps left over from my frantic attempts at baking. I had to delete those and re-import the armature+mesh.

Blender

Then, in Unity, I followed these steps (I did not need to re-bake my texture by the way):

Unity

In Unity, make sure to re-do everything like mark the rig as humanoid and force T-pose and stuff. I was frustrated for an hour because I forgot to do this and couldn't figure out why my animations wouldn't run.

| improve this answer | |
$\endgroup$
  • $\begingroup$ If I would have seen your post earlier I could have figure this out for you free. $\endgroup$ – Chris Feb 23 at 2:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.