0
$\begingroup$

Screenshot showing the distorted texture

Not sure what the reason of this distorted texture is. UVs are projected using Smart UV Project, and Subsurf modifier is used then. Tried subdividing the plane, but nothing changed.

How can I resolve this? I am assuming it has something to do with the mesh?

$\endgroup$
  • $\begingroup$ I hope you do not mind my edit. Let's try to use the terminology correctly. If I changed something not to your liking, please edit the question and correct it again. Hope this helps you to get better answers sooner. $\endgroup$ – Martynas Žiemys Jan 21 at 9:57
1
$\begingroup$

First connect the vertices that i marked with green lines then remove the vertecies/edges that i marked in red.

you can connect vertices by pressing J and to remove vertices/edges press Ctrl + X. also you should unwrap the model by just pressing unwrap instead of smart uv project.enter image description here

$\endgroup$
1
$\begingroup$

I was able to replicate your issue: enter image description here

The problem comes from the subdivision surface modifier and the option "adaptive subdivison"

There are several ways to fix this, depending on how you want your end result to look like.

Adaptive Subdivision doesn't like triangles very well (from my experience, could be wrong tough), so one step would be to try and reduce those as much as possible.

It also yields better results if edges are parallel to each other. So, essentially just a subdivided plane.

You can also turn off the adaptive subdivision, depending on what you want to do with your scene.

enter image description here

My question to you is, what do you want to do with the adaptive subdivison, do you want to make the stones "stick-out" as a real mesh? If not you can use a normal map.

$\endgroup$
0
$\begingroup$

Did you add the subsurf modifier after unwrapping the object? You have to do it the other way around: Try adding the modifier first and then unwrapping the object. Open the unwrap - menu and select "use subsurf modifer"

$\endgroup$
  • $\begingroup$ I have tried your suggestions before hand. No results. Thanks anyway! $\endgroup$ – Jacob Kowalik Jan 21 at 21:29
  • $\begingroup$ "Distorted Texture" probably because UV's are distorted. Subdividing will only make the mesh more complex and so more difficult to correct and why would you want to use a subsurf modifier on such a model? What you need to do is straighten out the left and right hand side of the UV's Then try to sort out the scaling problems of the different faces. In the UV editor select all the vertices on the left hand side > W to open the Align menu and choose the Align X option. repeat for the right hand side. Then the UV island rotate 90° so that its probably aligned with your stone texture. $\endgroup$ – 3fingeredfrog Jan 21 at 22:21
  • $\begingroup$ Then try scaling along X axis. But really you need to sort out those ngons in the mesh and make sure that both rotation and scale have been applied before unwrapping. Don't use the Smart Project for such a model. All that sloping wall needs to be unwrapped as a single island. Add Seams along top and bottom of the wall if necessary (and perhaps a couple off vertical seams if really needed) then use the simple basic UV unwrap. Then straighten top and bottom edges of the slope and scale along X axis. Without seeing the whole sloping wall I'm just guessing :) $\endgroup$ – 3fingeredfrog Jan 21 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.