1
$\begingroup$

I'm trying to add a single uv image texture on one part of my model. I have unwrapped using smart uv project, added the image texture node and plugged it in to base color and added the image in uv and placed it. And while the image does appear, it ALSO appears in multiple other places.

I don't get it, because not only is the image not showing on the other UVs, I've even moved everything OFF the image itself, so I'm not sure how it's even mapping to that part.

See below for images of what I am seeing. I have also included a link to the file if you want to take a closer look.

enter image description here

enter image description here

enter image description here

Link to file: Blender file example

$\endgroup$
2
$\begingroup$

Actually you think that the other parts of the mesh won't have the texture displayed because they are off the image in the UV/Image Editor but you need to know that the image is actually repeated as a pattern, that allows you for example to create seamless repeated pattern textures. So you need either to move your other faces on a transparent part of the image, or even don't unwrap these other faces of your object, or as suggested by bstnhnsl, choose Clip mode instead of Repeat in the Image Texture node.

Here is an example of an object that has the same image repeated on another face, while it looks like this other face is off the image:

enter image description here

If I increase the size of my mesh in the UV/Image Editor, you can clearly see what I mean:

enter image description here

$\endgroup$
  • $\begingroup$ A bit of a follow up - say I want to do 4-5 images in different places. I assume I put them all on ONE image texture and then manipulate the UVs to get them all where I want, correct? $\endgroup$ – MajorTom Jan 20 at 18:00
  • 1
    $\begingroup$ you can do that or you can assign different material to different faces, also you can create different uv maps and use the one you want in the Node Editor, with the Input > UV Map node. $\endgroup$ – moonboots Jan 20 at 18:03
  • 1
    $\begingroup$ by the way, you save the different UVmaps you create in the Properties panel > Data > UV Maps $\endgroup$ – moonboots Jan 20 at 18:30
2
$\begingroup$

In the Image-Texture-Node, there is a repeat option. Just set that to clip and you should be fine.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.