I've just passed the point where I'm no longer a total blender-newbie.

One of the most important lessons I've learned is that if something appears not to work, it's probably because there's a setting somewhere, in some panel that needs to be tweaked.

Now I'm trying out blender 2.8, and since I mainly do 2d-like animations of 3D objects (motion graphics style) - that's the first I test.

I notice that the addon "images as planes" is pre-installed and pre-enabled, but I have no menu-item 'images as plane' in the 'add' menu nor in the import menu.

Instead I try simply dragging an image in to the 2d-animation workspace, and yeah - it works!

I see my image - I don't know what kind of object it is, it seems like it may be a new kind of object called 'image' rather than a simple 'plane'-mesh with an image-texture/material - but I'm not quite sure.

However when I render - the image is not there. I've tried to add a simple cube next to the image, no texture, no material, just the cube, and the cube is rendered, the image is not.

I'm thinking "well at least they didn't take the mystery out of it" :)

So the very simple question is this:

How do I get that image to render?


I just realised that the added image is of type 'empty' - so it will never render. That answers my question ... I guess


When dragging an image from a folder to the 2D-anim workspace, an empty with the image is created. This will never render, and is probably meant as an reference-image.

Use "images as planes" instead. If the menu-items are not there (that was my problem) then disable and re-enable the addon "images as planes"

  1. Open userpreferences->addons
  2. Find "images as planes"
  3. Disable it - enable it
  4. Menu-entries are now under "file->import" and "add->images"
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.