1
$\begingroup$

I've got a principled glass shader and I've got the “screen space refractions” turned on. The glass has a thick base but you wouldn't know it to look at it? It's transparent ok and refracting the light ok, but the thicker base isn't apparent at all. Any ideas?

enter image description here

The principled shadernode looks like this

enter image description here

Wireframe shows that the cup has a base that isn't apparant in the render. enter image description here

$\endgroup$
  • $\begingroup$ See if mesh object doesn't have negative scale and has its normals calculated inside. Also yes, if you want glass Transmission value in shader should be set to 1. So far you seem to have almost perfectly glossy shader $\endgroup$ – Mr Zak Jan 18 at 22:49
2
$\begingroup$

Right figured this out, sorry my fault it wasn't actually a transmission issue (that was set to 1, I must of been fiddling with it when I took the screen shot). So the issue did occur even with a transmission of 1.

The problem was I think with everything being a bit flat. So I added a few edge loops and added a bit of curve to the base, making it more parabolic(?). Also, made sure I didn't have any extra faces hidden in the base.

Also used all the setting recommended above (thanks everyone, much appreciated) ie.

  • blend type to "Alpha Blend" in settings for the material
  • See if mesh object doesn't have negative scale and has its normals calculated inside
  • “screen space refractions” turned in settings for the material

enter image description here

$\endgroup$
1
$\begingroup$

Seems to be working for me.

You could try switching the blend type to "Alpha Blend".

enter image description here

Eevee:

enter image description here

Cycles: enter image description here

$\endgroup$
1
$\begingroup$

Your Principled BSDF node doesn't have transmission set to 1, so all transparency you see should come from Blend mode setting in the material which is not glass shader. Set Transmission to 1 and see if it helps, if it doesn't then try to change between Blend modes in material settings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.