0
$\begingroup$

So I'm making the models for a game that only uses vertex colors and no textures.

I've noticed that any color in blender 2.8 viewport looks darker that it actually is. I use vertex painting to paint the object in 100% white, I set the "flat" shading but the object is greyish.

Here's the screenshot with windows notepad opened above the blender:

enter image description here

It is obvious that the "white" torus isn't really white.

If I use color picker to pick the color from torus it will tell exactly what my eyes see: the picked color is actually 10% darker than real white. Even worse, If I pick the color and paint with it at the same area, it will paint with that darker color. Thus the color picker become unusable in many situations.

In blender 2.79 I've set the object to "shadeless" and it pretty much solved the problem, but this option isn't really there anymore.

Is there anything I can do to see the real colors in the viewport?

Thanks!

Andrey.

$\endgroup$
  • $\begingroup$ Did you see answers to similar questions before you posted it? $\endgroup$ – Lukasz-40sth Jan 18 at 12:47
  • $\begingroup$ I've searched for the solution and haven't found it if this is what you're asking about. $\endgroup$ – mega chebu Jan 18 at 13:26
  • $\begingroup$ Maybe it's displayed darker because of shading and/or light? Try setting the flat viewport mode. $\endgroup$ – Ronnie Mifiv Jan 31 at 12:50
  • $\begingroup$ "I set the "flat" shading but the object is greyish" $\endgroup$ – mega chebu May 28 at 6:22
1
$\begingroup$

EDIT (NEW SOLUTION):

I was browsing the bug reports and found the answer.
Set your Workbench viewport to Flat - Vertex Color.
In the Overlay Settings set the Vertex Paint opacity to 0, this way you are going to avoid the darkening effect of your vertex colors (if not they multiply by themselves)


This is an issue I am fighting right now with. The vertex colors viewport rendering is a mess and the solution I found is to tweak workbench to do the dirty work.

For painting if you want to have 1:1 vertex colors set your Solid view to:

  • Flat
  • Single (White)

(Object works too if your object color is set to white, you can then at least have outlines for complex scenes)

To see the whole scene with vertex colors I managed by setting Workbench's Rendered view as:

  • Flat
  • Vertex (note if you go in Vertex Coloring mode everything becomes darker)

And in color management

  • sRGB
  • Standard

So to work on on a scene with vertex colors you will have to swap between Rendered view and Solid view - It's terrible for color picking. I hope someone will fix this.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.