1
$\begingroup$

Operating system: macOS Mojave 10.14.2 Graphics card: Intel Iris Pro 1536 MB

Broken: 2.8 beta e57ee5934a30 Worked: 2.79

Problem: Blender window goes edge to edge, but interface only renders from the bottom left-hand corner to fill 60% of the screen. Mouse input corresponds to correct scale, but interface renders only in distorted area. Assuming it's graphics issue which can be solved by clearing an interface cache somewhere.

How to reproduce error:

  1. Open Blender on regular-resolution display
  2. Drag Blender window onto display with different resolution
  3. Interface scale breaks (cannot be reset)

How do I completely reset how the interface is being rendered so I can fix this interface scaling issue?

enter image description here

$\endgroup$
  • $\begingroup$ Using beta version. My bad, @batFINGER. Same problem in both alpha and beta. $\endgroup$ – Ethan Hansen Jan 18 at 4:39
  • $\begingroup$ The only working solution to this is quite simple. Use the final version, not the Beta. To get that bug recognized as a bug, you just have to go to Blender's bug tracker, create an account and submit a bug report. $\endgroup$ – metaphor_set Jan 21 at 3:45
  • $\begingroup$ @metaphor_set Thanks, but not super helpful. This occurs in 2.79 too, so not a bug. $\endgroup$ – Ethan Hansen Jan 22 at 1:12
  • $\begingroup$ If you tried everything to fix it and there are no other users that report the behavior than most people would say "Dude, check your system, reinstall your OS". That's what I call "not super helpful". Seeing that you try to get it to work on Mac OS, which has a significantly smaller userbase within the Blender Community, I (as a software developer with quite some experience under the hood) just give the best advice there is: Reporting the bug does not only help you, but also others who might stumble over it in the future. $\endgroup$ – metaphor_set Jan 22 at 3:44
2
$\begingroup$

This seems to be a bug. This is considered off-topic on Blender Stack Exchange.

See: What questions should be definitely off-topic?

Also this is to be expected since 2.80 version is not yet released and beta builds are still experimental. The bug should be reported:

enter image description here

You should ensure that you are using up to date graphics drivers, which on Mac OS means you should run up to date OS(it seems yours is up to date already). Blender 2.80 builds are built daily as well, so you can check if the bug is fixed in later builds, but that has little chance of happening if it is not reported.

Other than that, it seems Mac OS is not a perfect environment for doing 3d work at the moment. OpenGL support was dropped by Apple so if this by any chance is caused by a bug in their drivers, it is not going to be fixed in the future. I know it's not pleasant, but you may want to consider using another OS maybe in some sort of a dual boot set-up. It does not seem the situation with Mac OS is going to improve any time soon, it seems it might get worse.

$\endgroup$
  • $\begingroup$ This occurs in 2.79 as well, so not a bug. Graphics drivers are completely up to date. Using daily builds. — You're right, macOS isn't the best platform since Apple deprecated OGL. Will have to see what I can do in the meantime. $\endgroup$ – Ethan Hansen Jan 22 at 1:12
  • $\begingroup$ It is definitely not a feature - it's a bug. There may be some bugs in any version. $\endgroup$ – Martynas Žiemys Jan 22 at 6:15
1
$\begingroup$

Discovered the source of the problem: switching to screens with differing DPI. The difference between Retina screens e.g. 2015 MBP and 170 DPI Apple Cinema displays causes the Blender interface to break. Will report this on bug tracker.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.