0
$\begingroup$

The mesh is ported through a game. So the faces are triangles instead of quads. It comes with 4 textures. The diffuse, the normal map, the specular map and the subsurface scattering map. When I apply only the diffuse texture, it looks fine. After I apply the normal map as well, It becomes what the pics show. The back of the mesh is black. And the triangles pop out of nowhere. It happens too when it comes to the nude body. But the armor/clothes are fine.

BTW, should I apply the specular map and the subsurface scattering map as well? Since the principled shader already did so well, I try applying the specular map and it looks no different. And I don't know where should I apply the subsurface scattering map.

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

Try to change tangent space to different one and see if that'll work. Its always better to apply the specular map and the subsurface scattering map if they have details in them. Try connecting subsurface map to sss color input of bsdf shader (havent used sss maps yet so cant say for sure)?

$\endgroup$
  • $\begingroup$ I follow your advice. Please read my comment down below. Thank you very much. $\endgroup$ – Miyashiro Jan 14 at 10:51
  • $\begingroup$ Try SSS map to subsurface color input and see which will look best. Try to shade smooth mesh and recalculate normals as well (shift+n in edit mode). On 2nd screen normal map applied fine it seems, hard to say with such lighting. $\endgroup$ – Blending in Trance Jan 14 at 11:13
  • $\begingroup$ Put it to subsurface color input, recalculated normals don't seem to fix it. I have already smooth shaded the mesh. The normal map contains green and red areas. I see other armor/clothes' normal map is blue only. The normal map I baked, following the youtube texture tutorial, is also blue only. $\endgroup$ – Miyashiro Jan 14 at 11:40
  • 1
    $\begingroup$ Yeah, havent noticed it earlier, normal map look weird. Then it just incompatible with blender, only with engine of game. $\endgroup$ – Blending in Trance Jan 14 at 11:51
  • $\begingroup$ Is there anyway I can make it compatible? Also, whenever I view the textures through the principled BSDF shader, some weird triangles pop out of nowhere. If I choose to view only one of the texture, like only the diffuse one, It looks normal and no weird triangles. Why is that? Pictures at the comment down below. $\endgroup$ – Miyashiro Jan 14 at 12:36
0
$\begingroup$

Please go to object properties > Uncheck custom normals. Also try to check if there´s additional Vertex groups. Sounds like you got vertex paint mapping attributes.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.