0
$\begingroup$

The title sums it up. I've been putting together animations for one of my projects over the past week. I have all different kinds of animations in this file, running, attacking, jumping, crawling, etc. Today I was working on a sprinting animation where the character would have to be leaning forward. I noticed that rotating the hips (not the root) of the character would also tip it on the other frames of the animation. This was convenient for me. Until all of the rotations started applying to all the frames, making any tweaks worthless as it would apply the pose of a bone to all the other keyframes. I just found out that it wasn't only applying the transformations to all the keyframes in the animation I was working on, it was applying the transformations to all keyframes of ALL my animations. This is absolutely devastating. The recovery didn't help, my entire project is ruined and it will take hours of work to get it back to where it was.

Does anyone know why this happened? Is there a button I accidentally hit? What setting is this? It absolutely was not doing this before. As I said, I have over 20 animations in this file, many of them also used the hip bone and none of them applied the transform to all the other animations. It isn't just the hip bone either, any bone that I modify gets modified in all other animations on all of their keyframes.

EDIT: My other blender files don't have this issue. It'd be completely nonsensical that animators wouldn't be allowed to touch core bones while animating. I'm fairly positive that this is a settings issue. I've somehow turned on a setting that applies the rotations of specific bones to all keyframes of all animations.

Video: https://www.youtube.com/watch?v=I1pn5VH0p7Q&feature=youtu.be

$\endgroup$
  • 1
    $\begingroup$ If not all bones are keyframed in your action then a value can be "held over" into the next. Quite possibly you simply needed to zero all bones to reset those of the next animation... or kf all bones on first and last frame of action. $\endgroup$ – batFINGER Jan 13 at 2:08
  • $\begingroup$ All bones are keyframed, all bones are also keyframed on the first and last frames of all actions. Whenever I move the hips it applies the hip changes to all frames of all animations. I'm fairly certain it wasn't doing this before but its possible that my past rotations were so subtle I wasn't noticing the change. $\endgroup$ – Collin Jan 13 at 8:03
  • $\begingroup$ I can barely understand from your question, what batfinger answered. Could you upload a gif showcasing the problem. Or the blend file and explain a few steps to reproduce the problem? $\endgroup$ – Leander Jan 13 at 9:24
  • $\begingroup$ youtube.com/watch?v=I1pn5VH0p7Q&feature=youtu.be I uploaded this video, hopefully this helps. If I sound annoyed its not because I'm angry at you or anyone else, I'm mad that a weeks worth of work is gone and I've been losing sleep trying to figure out why. $\endgroup$ – Collin Jan 13 at 9:52
0
$\begingroup$

Undo that original hip rotation, rotate the object by grabbing the whole object, then rotating it (A,G,R). I also found the Rest Pose can never be changed after animating without disrupting the animations.

$\endgroup$
  • $\begingroup$ That's definitely a solution but it's really not gonna fly for me. My IK setup is very specific and rotating all bones at once is wayyyy to sloppy. And I don't understand what you mean by changing the rest pose. As far as I knew the rest pose couldn't be changed by making keyframes. If it did, that would defeat the entire point of animation. When I reset the bones they go back to their rest pose so I don't think that's the problem. $\endgroup$ – Collin Jan 13 at 7:58
  • $\begingroup$ Additionally, my other animated projects in blender don't have this issue. This really seems like a setting that accidentally got turned on. I do not believe that blender would prohibit you from animating with one of the core bones of a model. I'm 99% sure this is a settings issue. $\endgroup$ – Collin Jan 13 at 8:11
  • $\begingroup$ If you make an animation then create and apply a new rest pose any prior animations can have their loc, rot & scale messed up permanently. $\endgroup$ – Toby Jan 13 at 8:12
  • $\begingroup$ I'd say the original problem was that original hip rotation though. $\endgroup$ – Toby Jan 13 at 8:14
  • $\begingroup$ I'd assume that to be the case but I'm not applying rest poses I'm making keyframes. This is a new issue that was not happening during the last week of work and it doesn't exist in any of my other projects. I'm pretty sure this is a setting that has accidentally been turned on on some of my bones (the ones whose transformations carry over to every other frame in this project.) $\endgroup$ – Collin Jan 13 at 8:15
0
$\begingroup$

It looks like if you change the rotation type while keyframes exist it breaks the animations. There is no fix to this other than sticking with the rotation type you started the animation with. To prevent this in the future I'll be making sure every bone starts in the rotation type I want before doing any animation

$\endgroup$
  • $\begingroup$ It can be fixed with a script somewhat. $\endgroup$ – batFINGER Jan 13 at 11:05
0
$\begingroup$

Have you tried Inherit settings?enter image description here

$\endgroup$
  • $\begingroup$ What does it do, and how does it help? $\endgroup$ – batFINGER Jan 14 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.