0
$\begingroup$

I have copied a walk cycle action from one rig to another - from a male to a female. When the timeline is scrubbed the new action works fine. But, when I try to edit the bone's positions at a particular keyframe, it's like the rig is disconnected from the mesh. The rig moves, but the female figure it's the parent of stays still.

Perhaps this has to do with the fact that I made these adjustments yesterday and got it working, but I hadn't created a fake user for the copied action and it wasn't saved. Now that I've worked a little more with pose libraries and actions (which I'm just learning), I tried to delete some extra ones of both, and somewhere in that process it created something problematic in the file. I got a warning on that animation this morning that it was corrupted and I should 'sanitize' it. I had to look that up here to realize that meant press the lifesaver icon to make the action suitable for use as a pose library.

It's a small file so I'm just going to attach it, as what the solution is may depend on exactly what I've done wrong here.

$\endgroup$
2
$\begingroup$

You have enabled Delay Refresh on the Armature.

From the manual:

When enabled, the bone does not deform its children when manipulating the bone in pose mode.

To make the mesh deform at all times, uncheck Delay Refresh.

delay refresh option

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.