1
$\begingroup$

I wanted to export .OBJ file to keep layers from Rhino in Blender. But when importing to Blender nothing shows and layers don't work either. Here are screenshots of export process:

Model in Rhino:

model in Rhino

Settings used to tessellate the model into polygons:

tessellation settings

OBJ export settings:

obj export settings

result in Blender:

Blender result

I also tried it in Windows enviroment and nothing changes. Another weird thing is that the .OBJ file is 920MB in size.

Thanks anyone for any advice in advance

$\endgroup$
  • 1
    $\begingroup$ 1 - OBJs don't have layers. 2 - You are not using Blender 2.8 3 - Blender doesn't have layers $\endgroup$ – Duarte Farrajota Ramos Jan 11 '19 at 23:16
  • $\begingroup$ Which software you are using? Doesn't look like blender at all. $\endgroup$ – Yash Feb 9 '19 at 18:53
  • 1
    $\begingroup$ @Yash He's using Rhinoceros to export a model as OBJ and trying to import it into Blender. $\endgroup$ – xxbbcc Mar 6 '19 at 2:47
  • $\begingroup$ I would suggest you take a look at the Rhinoceros importer add-on. $\endgroup$ – Robert Gützkow Mar 8 at 10:46
  • $\begingroup$ Tried it a while ago and didn't get it to work @RobertGützkow $\endgroup$ – brockmann Mar 8 at 18:22
2
$\begingroup$

Data Transfer always involves two components: An export process and an import process. Both of them need to be aligned with each other to produces a correct result - or at least a desired one. Now, we don't have your source files available, but let's tackle your comments bit by bit:

Another weird thing is that the .OBJ file is 920MB in size

This is basically buried in your tessellation settings. Your model is an architectural one, meaning it spans across a dimension of roughly 100 meters. Rhinos internal units however deal with sizes of millimeters or centimeters (to be checked within your Rhino settings), and the tessellation refers to that. The defaults are crafted to objects at the size of a coffee machine would tessellate nicely. You're feeding something considerably bigger to it, so the settings for tessellation can be lowered to compensate for that. Especially the minimum edge length seems to be far too fine from where I stand. As soon as objects are curved, this will result in very dense triangulation.

But when importing to Blender nothing shows and layers don't work either

The first part is a misconception. Check your own screenshot and have a look at the right on the Outliner area:

Check Outliner

You'll notice that there are a bunch of objects. Generally that means that data has been transferred, just you don't see it. And this leads to the second part, which is:

OBJ sucks at what it actually CAN store

  • OBJ has no definition in the file format for layers, as has been mentioned in the comments already. You will only get as far as achieving at least that things come in as more than one object (which is the case for you already), but that's about it.

  • Worse than that, OBJ has no means of storing units. That means, when you try to store a vertex located at (1.0, 0.0, 0.0), OBJ will happily write down the numbers, but not what 1.0 actually means. Millimeters? Meters? Feet? Inches? You won't know. So what breaks in your scene is that Rhino exports the numbers very likely as millimeters, but Blender on the import side interprets that same raw numbers as meters. This results in your scene scaled up by a factor of 1.000, too big to see it in the viewport.

The worst part however is that the OBJ importer in Blender has no Scale setting either, which you could use to apply that unit compensation. Blender 2.82 does have it for the exporter, but not for the importer, for reasons that are beyond me. So the only thing you can do on the Blender side is to scale down the scene using the 3D Cursor as the origin by a factor of 1.000. Maybe you have said unit compensation on the Rhino side.

| improve this answer | |
$\endgroup$
0
$\begingroup$

These settings work for me when exporting an .OBJ file Export Settings

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.