the method I was told to use involving mix shader doesn't work

enter image description here

  • $\begingroup$ The problem isn't that the alpha isn't working. You've connected the mix shader's output to the base color input of the principled shader. Shader output isn't a color, and can't be connected to color input sockets. The socket types are color coded. Some of these can be connected to each other, but generally you should make sure sockets you connect are of the same type. Look at the accepted answer to the suggested duplicate question, to see how it's connected, and take a look at Node Parts in the online manual. $\endgroup$ – user27640 Jan 11 '19 at 14:23

The setup you have there will not work. You cannot plug a shader into the Base Color socket of the Principled BDSF. That socket is expecting RGB input. Generally, you can only plug a Shader into the Material Output or a Mix Shader node.

Your Mix Shader node should come after the Principled BSDF. It should mix between the Principled BSDF and the Transparent shader, and plug into the Material Output node.

As an alternative, you can also use the transmission property of the Principled BSDF itself (towards the bottom), eliminating the need for mixing. I would personally advise that you do this as it's cleaner and easier. You then have just one shader.

That would be it for Cycles. To get it to work with EEVEE, however, there are two additional settings:

  1. In the materials panel for your material, under Settings, you need to change the Blend Mode to Alpha Blend.
  2. In the render panel, you need to turn on Screen Space Reflections, and then tick Refraction.

That should do it.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.