1
$\begingroup$

I'm an absolute Blender newbie and just taking my first steps. I've created some shape and want to apply coloring and texture now, after placing lamps all around my object to see it, I now can't switch to Edit Mode and I'm not sure why, can anybody help me please?

I only have Object Modein the mode selector:

enter image description here

I'm using version 2.79 on Windows

$\endgroup$
3
  • $\begingroup$ What is you just press the "Tab" key? $\endgroup$ – rob Jan 9 '19 at 14:55
  • 3
    $\begingroup$ Select object which can have other interaction modes first; switching interaction modes is done on the active object. Most likely in your case you have lamp selected and it can't have Edit mode; select a mesh. @rob if there aren't interaction modes available in the dropdown list then Tab won't work as well as it will face the same issue $\endgroup$ – Mr Zak Jan 9 '19 at 14:59
  • $\begingroup$ @MrZak you should put that in an answer $\endgroup$ – Bombinosh May 5 '19 at 16:12
1
$\begingroup$

I just had the same isuue (and I'm a COMPLETE newbie to Blender). I just closed the program and opened it again, and then clicked "General" when the program opened again/ the window popped up. Now I've got all the options in the top left-hand corner.

$\endgroup$
1
$\begingroup$

I found that edit mode only works when an object is selected. If you can't select it, go to the objects panel and click on your object. Then click tab and you'll switch into edit mode. This is using Blender 2.9.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.