0
$\begingroup$

First: i have searched and read all the threads, tried the solutions! I just can't get the rigging to work. I have a model and a rig, when i try to apply the parenting-part (With automatic weights) i get the dreaded "Bone heat weighting"-error. I have applied/cleared all scales/rotation, removed doubles, set a subsurf before the armature-modifier.... i just can't figure it out. The .blend-file is attached, hope you with more knowledge can figure out why it's not working and help me with a solution.

$\endgroup$
1
$\begingroup$

You need to remove doubles: Select your mesh, go in Edit mode, select all, press W > Remove Doubles, and on the bottom of the Tools panel (on the left), choose a Merge Distance of 0.2mm

$\endgroup$
  • $\begingroup$ Thanks! Never knew about the Merge Distance! Is 0.2mm the best option? $\endgroup$ – Jaco Jan 11 at 7:42
  • 1
    $\begingroup$ It's just the distance below which you want the vertices to merge, so it may be more or less, depending on the object, you need to test ;) in your case it seems like it's the best option $\endgroup$ – moonboots Jan 11 at 7:53
  • 1
    $\begingroup$ by the way, when you apply a tool, always take a look at the bottom of the T panel, most of the time you can play with parameters (it will be more visible in 2.8) $\endgroup$ – moonboots Jan 11 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.