3
$\begingroup$

I've heard that it should be in the output but it's not there. It just has material output. I've enabled node wrangler which I've read should make the viewer node visible.

$\endgroup$
  • $\begingroup$ Just press Ctrl + Shift + Click (while the node is selected for which you want the viewer node) after enabling the node wrangler addon and it should connect with material output node using viewer node otherwise you can use emission shader as suggested in answers. $\endgroup$ – Rakesh choudhary Aug 1 at 12:48
4
$\begingroup$

The viewer node is actually an Emission BSDF with its label changed to "Viewer." ShiftCtrlLMB on any node with an output and the the first output will be connected to the color input of "Viewer." Successive clicks will cycle through all the outputs of the desired node. Also note that if your scene exposure is changed, the viewer's strength will automatically adjust to compensate, but it will not compensate for changes to gamma or adjustment curves.

| improve this answer | |
$\endgroup$
1
$\begingroup$

Shift, ctrl and left clicking on the grey fresnel factor node added a viewer node.

| improve this answer | |
$\endgroup$
1
$\begingroup$

For Macbook Users, it is Shift+Ctrl+LMB. Using Shift+Cmd+LMB won't work.

| improve this answer | |
$\endgroup$
1
$\begingroup$

It is possible that your node wrangler is not activated. For that, go to Preferences (under Edit) >> add-ons >> check on node wrangler if not activated. Then press Shift+Ctrl+Left click on the grey fresnel factor node (as mentioned above).

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.