0
$\begingroup$

Here is image and it will tell everything. Left is rendered, right one is as you can see object mode shown as materials.

I am learning blender and this is my first project after watching one tutorial so i have never came up this problem.

$\endgroup$
1
$\begingroup$

It looks like you have more than one bench, occupying the same point in space. And this can destroy reality. Try to grab your bench with RMB in any direction. If there is another one, just kill it. Maybe it's hidden from the viewport, so first press Alt+H to reveal your hidden stuff.

$\endgroup$
  • $\begingroup$ Yea. I have hid that parts but didn't know there is separate button to hide from render too. $\endgroup$ – Aleksa Ristic Jan 7 at 16:12
  • $\begingroup$ In the outliner there are icons with an eye, arrow and camera. The camera icon means visibility on render. But there is an easier way. All unused object you can move to unused layers (shortcut is M in object mode), and disable the whole layers altogether (Shift + [Alt] + digit from 1 to 0 (not numpad)). Only visible layers will be rendered. $\endgroup$ – Mechanic Jan 7 at 16:31

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.