3
$\begingroup$

How to make transparent background in blender 2.8 with HDRI on? After selecting "Film" - "Alpha" -> "Transparent" I still have my HDRI on the rendered image

Please help

$\endgroup$
5
$\begingroup$

Transparent Background

In general - Render Properties - Film - Transparent works (viewport and render)

enter image description here

To Save render with transparency - Render Properties - Output - File Format - PNG and Color - RGBA has to be set (or any other format that supports alpha channel).


Hide Background

For viewport you can hide background image in Shading properties by changing World Opacity set to zero.

enter image description here

Notes:

  • Works for Eevee and Cycles
  • HDRi is file format, but important in terms is that background in blender use equirectangular texture type. It doesnt has to be necessarely HDRi that refers to a high dynamic range image.
| improve this answer | |
$\endgroup$
2
$\begingroup$

Have you tried setting the color of the output to RGBA? I had a similar issue and this seemed to fix it.

enter image description here

| improve this answer | |
$\endgroup$
1
$\begingroup$

I'm not sure if you try to render a final output (F12) but it is working, inside the viewport is not. But in the final render it is

enter image description here

Good Luck

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ You're right! But is it possible to disable this image in preview? I have very bright HDRI in my scene (and i need taht bright) and it's very annoying to see something different than in final render $\endgroup$ – user53826 Jan 7 '19 at 16:32
  • $\begingroup$ Not that i know, sorry, you could try to bake the indirect Light (Render Settings>>Indirect Light>>Bake indirect Lighting. $\endgroup$ – Emir Jan 7 '19 at 22:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.