1
$\begingroup$

I got a problem using glTF exporter for Blender (To upload 3D content on Facebook). I downloaded the last version of the add-on on this site: https://github.com/KhronosGroup/glTF-Blender-Exporter

The problem is that there is only 2 node groups for Cycle rendering, glTF Metal and glTF Specular, but there's no glTF Diffuse node group for instance, and using the normal shader node provided by Blender don't work while exporting.

So I was wondering how to get this node group, or if I have to create it, maybe I miss something, I don't know.

Thanks for reading ! (PS: I got the last Blender Version and I followed the Khronos Group tutorial, I found nothing)

$\endgroup$
1
$\begingroup$

A couple of issues to note here:

  • The glTF-Blender-Exporter project is obsolete now, superceded by glTF-Blender-IO that includes an importer. The new project can be downloaded from GitHub and manually installed in Blender 2.79x, and it also ships pre-installed in Blender 2.80 Beta.

  • The newer glTF-Blender-IO project can export directly from Blender's own "Principled BSDF" node, so you can lose the custom glTF Material node if you don't want it.

  • The glTF format itself doesn't contain nodes (at least in the current 2.0 form). The core material in glTF 2.0 is a PBR material with channels for Base Color, Metallic, Roughness, baked Ambient Occlusion, Emission, and a (tangent-space) Normal Map. So the exporter is looking for textures or colors assigned to the Principled node, or to its own glTF Material custom node, and trying to copy those textures into the export. The actual inner workings of whichever node you use may have an effect on Blender, but not on the resulting glTF file.

For the case of purely diffuse rendering, in the metal/rough workflow this is accomplished by setting the metallic value to zero (black). You may also want to experiment with various high roughness values (white, or near white) to see what looks best.

$\endgroup$
  • $\begingroup$ Thank you for your answer. I'll try your diffuse tip ;) $\endgroup$ – Alois Coissard Jan 7 at 21:00
1
$\begingroup$

Just setting metallic to black(0) and Roughness to white(255) should solve the problem of getting a diffuse shader.

I think that your shader is diffuse but you cant see the colors when you export it out. I had the same problem, I solved it by using the Emission node packed with the two nodes you mentioned.

enter image description here

All those texts are using emissive nodes.

Also applying material on text objects doesnt work. You have to break them to mesh, draw out UV map and then apply texture(also using emissive map).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.