0
$\begingroup$

Running Blender 2.79 on Kubuntu Linux 18.10 and I encounterred the following problem

spent half a day modelling a part for 3d printing

it's a single object in the scene with many others

when I try to export it , blender always creates a non usable basically empty file with just 84 bytes when I try to export STL.

I tried exporting to other formats and then opening them back up in Blender ... doesn't work ... exporting to .obj gives a 92 bytes "empty" file, for example

other objects in my scene export just fine

just this object that I edited won't export (yes, i have terrible geometry and I've used a couple of applied booleans when making it but surely it MUST export at least SOMETHING, right ? )

edit: tried creating new object ... doesn't even export primitives ... only objects that were already in the scene export sucesfully edit: found a workaround : save a copy of entire scene, delete EVERYTHING except that object and then when I export, i uncheck the "Selection Only" and it works ... so apparently the "selection only" has something to do with it ... any ideas on what could be causing this ?

$\endgroup$
  • $\begingroup$ the 'selection only' is a recent feature (2.76 doesn't have it yet). This means nothing, but new features tend to glitch. The stl exporter is in python (scripts/addons/io_mesh_stl), so you can hack / debug it. $\endgroup$ – Mechanic Jan 6 at 7:19
  • $\begingroup$ I don't think export "Selection Only" has anything to do with this issue, I've been using that for years without issue. In the Outliner, when I selected "Active" I could see the selected object, but when I switched to "Selected Objects" then nothing would show up unless I selected meshes that were problem free. The models I made were simple Icospheres with a couple displace modifiers. Something I've done a hundred times over the past 6-7 years. Something fundamental is broken in recent versions. When I isolated the model, it mostly fixed the issue like with you so no bug report is likely. $\endgroup$ – MarcClintDion Jun 15 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.