3
$\begingroup$

I am trying to render refractions in EVEE, and I'm having problems. I can see the effect beautifully rendered in the viewport, but it won't render when I try to render out to an image or an animation (F12). The scene just renders without the effect working at all.

I've tried using a glass shader, a refraction shader, and a principled shader. None have worked. Hopefully the below screenshots will clarify all the settings I'm using.

Please note, I am using a beta of Blender 2.8 and I'm working on a project where I need EVEE as the actual renderer (not just for previewing). The time frame of the project turnaround I'm working on precludes me from using cycles. Any thoughts on this would be VERY HELPFUL!! Thank you!

material settings

material settings

additional material settings

additional material settings

render settings

enter image description here

Here is what the rendering looks like in the viewport; it's a red object inside of a block of rough glass

Here is what the rendering looks like in the viewport; it's a red object inside of a block of rough glass

Render out looks like this

enter image description here

$\endgroup$
1
$\begingroup$

Well this is resolved. I realize that I had the red item inside the block of glass marked to not render. Sorry folks!

$\endgroup$
  • 1
    $\begingroup$ You can mark your question as answered yourself, just click the check mark $\endgroup$ – aliasguru Jan 6 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.