0
$\begingroup$

I am trying to model a snooker table for an Unity game and I have an issue with strange shadows on the cushion: enter image description here

This is how I modeled the curved edge: enter image description here

It's not an Unity issue because if I choose smooth shading on Blender, I get some strange behavior too: enter image description here

I tried to recalculate the normals and I also checked if the top vertices are on the same plane and they are. Am I modeling it wrong?

$\endgroup$
4
  • $\begingroup$ perhaps share this part of your object? blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    Commented Jan 4, 2019 at 22:37
  • $\begingroup$ I added it at the bottom of the post $\endgroup$
    – Bogdan C.
    Commented Jan 5, 2019 at 13:05
  • $\begingroup$ This looks a little like the shading problem here blender.stackexchange.com/questions/126657/… Try moving your lamp about or disable Shadow in the Light menu. $\endgroup$ Commented Jan 5, 2019 at 13:44
  • $\begingroup$ @3fingeredfrog I have no lights in the blender file. Moreover, the strange shading on my model occurs on a flat surface. $\endgroup$
    – Bogdan C.
    Commented Jan 5, 2019 at 13:57

2 Answers 2

1
$\begingroup$

Sometimes you get this issue with orphaned vertices, which can be fixed with Merge By Distance option. And sometimes it needs to be UV reunwrapped, as I think you have discovered.

$\endgroup$
0
$\begingroup$

It seems I fixed it. I am still learning so I am not sure what fixed it but I: 1. applied the modifiers 2. removed UV Maps on all meshes on Object Data 3. exported to Unity 4. checked Generate Lightmap UVs box in asset imported in Unity

I think it was an issue with UV Maps.

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .