4
$\begingroup$

I have set my armature to pose mode, and now want to select the rigged mesh so that I can weight paint it. The only way I can select the mesh as the active object is to set the armature back to object mode, which I don't want.

Using blender 2.8

$\endgroup$
  • $\begingroup$ Created and self answered since I had to hunt a bit to figure this out last night, and I suspect many others will benefit as people start using 2.8 more. $\endgroup$ – Sazerac Jan 4 at 4:34
5
$\begingroup$

This has to do with how editors/modes have changed in 2.8 (presumably related to multi object editing?)

There is an option in the edit menu called Lock Object Modes which forces the mode to be consistent across all objects. If an object doesn't support the current mode then it cannot be selected. Disabling this mode allows leaving the armature in pose mode and then selecting the mesh:

Menu option

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.