0
$\begingroup$

I have two layers of geometry for the eyes: The top one for the eyelids and the bottom one for pupils. This is what it looks like without the 2nd layer: enter image description here

And this is what it looks like with both layers:

enter image description here

For some reason, the transparency that's only applied to the 1st layer is showing through the 2nd layer:

enter image description here

How do I fix this?

EDIT: .blend file download

$\endgroup$
  • $\begingroup$ Could you maybe share the .blend file or some more screenshot of the setup you have? It is hard to understand what geometry you are using and what for and how the shaders for it are made. $\endgroup$ – Martin Z Jan 3 at 7:27
  • $\begingroup$ @MartinZ Added a link! $\endgroup$ – nissku Jan 3 at 9:44
  • $\begingroup$ It seems you forgot to pack the textures, so I am not able to see them. I would make the eyelids with actual geometry, so they can be animated with shape keys or something like that, or I would animate the shader for the eyes itself (although I do not use Blender Render so I cannot advice on how to do this with it). It is still unclear to me what you intended to do with this as it is. $\endgroup$ – Martin Z Jan 3 at 9:58
  • $\begingroup$ Just a guess but it's worth a try. It looks like the 'Transparency' box might need to be ticked. In the 1st layer's properties (cube icon at right) go right down to the "Display" tab. It's in there. Tick or untick the Transparency box. If that doesn't work, try it for the 2nd layer. $\endgroup$ – Edgel3D Jan 4 at 0:21
  • $\begingroup$ @Edgel3D That did the trick! Thank you so much!! $\endgroup$ – nissku Jan 4 at 23:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.