0
$\begingroup$

Experiencing some unclear problems with Blender 2.79, I uninstalled it with the intent to reinstall a fresh version using the same Linux mint Sylvia 18.3 operating system.

Then realized that the current repositories I used offer an older Blender, version 2.76.

So I downloaded Blender, version 2.79b from Blender.org then unpacked the archive and tried to run the Blender executable. None of the files I found seem to be 'the executable'.

I then tried the terminal with sudo add-apt-repository ppa:thomas-schiex/blender. Did get a long message ending by

< --------- 'Executing: /tmp/tmp.YmGQR1O6nu/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 42A98114 gpg: demande de la clef 42A98114 sur le serveur hkp keyserver.ubuntu.com gpg: clef 42A98114 : « Launchpad PPA for Thomas Schiex » n'est pas modifiée gpg: Quantité totale traitée : 1 gpg: non modifiées : 1'

------- >

But

The Blender installation did not seem to occur. Only obtained a small text file in /etc/apt/sources.list.d

The terminal's long message talks about adding a user to video in order to operate CUDA. Did not think it was needed since Blender 2.79 used to work on this same computer previously. Maybe I was wrong about that, did not want to risk more damage fiddling with the unknown.

So How can I find the executable Blender file in the downloaded package ? What is the name of that executable file ? or / and what should be my next step with the process using the terminal ? should I follow the ­­'sudo adduser video' ? How does that work ... Is the terminal prompt, user@Latitude-E6330'the ?

Thanks a lot for your help.

$\endgroup$
  • 2
    $\begingroup$ Surprisingly enough the executable is named "blender" Run from prompt in the directory that contains blender exe with ./blender (the same folder will have a 2.79 folder, a blender.desktop shortcut etc.) $\endgroup$ – batFINGER Dec 31 '18 at 6:18
  • $\begingroup$ Thanks, batFINGER. I can appreciate you read and answer aswell as the irony of your answer. I did not get the blender executable mainly, I am sure, because I did not finish the installation process. Repeating apt-get install blender lead to an actual installation of the 2.76 version of blender. I also tried apt-get install blender-edge and obtained the following message : $\endgroup$ – Jean Pierre Jan 1 '19 at 20:33
  • $\begingroup$ <Dépend: libopenimageio1.7 mais il n'est pas installable Dépend: libopenshadinglanguage1.8 mais ne sera pas installé Dépend: libpython3.6 (>= 3.6.3) mais il n'est pas installable Dépend: python3:any (>= 3.6~) E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».> I know ... my terminal speaks French ... I have him learn English or translate if appropriate. Merci encore $\endgroup$ – Jean Pierre Jan 1 '19 at 20:41
  • $\begingroup$ Just to make things clear I try to re-install version 2.79, which was ... almost doing what I asked it and can only obtain a previous version, 2.76. $\endgroup$ – Jean Pierre Jan 1 '19 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.