0
$\begingroup$

I have searched around and cannot seem to find any relative info on this issue. Only one forum post that claimed you need to subdivide the low poly mesh more in order to get rid of the mesh grid baked. However this does not work as it just makes the mesh grid higher resolution and appears on the low poly model when applied.

I have a high poly mesh I have sculpted in Blender that I am baking on to a low poly version of it. I cannot subdivide above 6/7 without crashing my pc as the high poly mesh is already really high. This is not a practical solution.

I even retopped the high poly mesh to see if my low poly was simply too different. didn't make a difference.

As you can see in the image. Which is the result of a bake onto a low poly mesh with a 3x subdivide modifier on it. It should be mostly flat but it has all these waves, which correspond to the faces on the mesh. My ray distance is set to 1. The high mesh is directly on top of the low mesh as required. I have adjusted the ray distance a lot and never makes a difference to the mesh imprint.

Thank you in advance for any help with this! Driving me nuts. I've been using Maya and Mudbox along with Substance Painter during university but want to have a blender/substance workflow for myself since I prefer Blender and also Maya are greedy with their licenses.

enter image description here

$\endgroup$
  • $\begingroup$ Ok for anyone with this issue I just figured out. Go into edit mode on the low poly object, and in the shading/uv tab on the left toolbar choose Smooth under faces before baking. For some reason all tutorials on baking normals fail to mention this. $\endgroup$ – Molmez Dec 29 '18 at 19:37
  • $\begingroup$ Glad to hear that you figured it out! If you want, you can answer your own question as an answer and that will help others find this problem/solution better. $\endgroup$ – Kirbinator Dec 29 '18 at 23:33
1
$\begingroup$

You definitely shouldn't need subdivisions to get non grid bakes. Subdivisions can help with extreme gradients, though.

My guess is that you have the low polygons normals incorrectly prepped for the bake. When you bake details from high poly to low the low poly models normals affect how the rays are cast. Make sure that your lowpoly mesh object is set to "smooth" from the: 3D View-T panel-Tools-Edit-Shading-Smooth before exporting. In my tests if you set your low poly to Smooth the bakes come out without the lowpoly edges showing up in the texture. If you set it to Flat the bake comes out with the lines.

Sometimes you will need to control smoothness/Sharpness at the low poly level, though. In this case first the the object to smooth shading. Then enable auto-smooth in: Properties panel-Object Data-Normals and set the value to 180. (Or whatever value you want to use as sharpness. At 180 whole model will be treated as smooth shaded, because 180° doesn't really ever exist in normal model.) Then you can in edit mode set the edges you want as "sharp" by selecting those edges, ctrl-E, mark sharp. This is useful with hardsurface/mechanical stuff. (However, note that the Normals-Autosmooth is very resource intensive when polycount rises so definitely disable it when working with subdivision surfaces.)

I hope the smooth shading before exporting lowpoly fixes your problem!

$\endgroup$
  • $\begingroup$ thanks haha I just figured it out at same time as you posted and I posted the answer, it then refreshed and showed me your response! It fixed it. appreciate the help. Thank You! Very helpful info :) $\endgroup$ – Molmez Dec 29 '18 at 19:39
0
$\begingroup$

Ok for anyone with this issue I just figured out. Go into edit mode on the low poly object, and in the shading/uv tab on the left toolbar choose Smooth under faces before baking. For some reason all tutorials on baking normals fail to mention this.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.