1
$\begingroup$

I setup a VirtualBox machine under Windows for dev related stuff (python, visual studio etc), everything works except that I cant run Blender :( it crashes with

 ./blender.exe
AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFD68CC702C
Module  : C:\Windows\system32\VBoxGL.dll

I can see that the gl driver is incompatiple which is fine but I am wondering if there is a way to make it work in some software opengl on Windows guest.

thanks

$\endgroup$
  • $\begingroup$ The VirtualBox has extensions, you can download and install. And there is some 3D-related settings for your VM. But the problem is not in video, but in sound. Try to disable the soundcard in your VM. $\endgroup$ – Mechanic Dec 29 '18 at 9:09
  • 1
    $\begingroup$ I do not think that it has anything to do with sound. And yes I hvae Virtualbox extensions installed and have 3d accelaration enabled. blender -nosound AL lib: (EE) ALCmmdevPlayback_open: Device init failed: 0x80070490 Error : EXCEPTION_ACCESS_VIOLATION Address : 0x00007FFD73C1702C Module : C:\Windows\system32\VBoxGL.dll $\endgroup$ – yarun can Dec 29 '18 at 19:06
  • $\begingroup$ And what do you think it's all about, if not the sound (AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead)? ;-) Sometimes I see sound errors of blender via rdp on servers, where no sound installed. But it does not crash it completely. $\endgroup$ – Mechanic Dec 29 '18 at 22:18
  • $\begingroup$ AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead is warning, not an error and has nothing to do with crashes, neither in this case nor in others. It happens pretty much for everyone where system setup and Blender's setup is set to different sound settings, e.g. developer.blender.org/T44416. Crash in case of running from VirtualBox is likely related to lack of graphic card in guest system (since it can't see physical card). If using VB solution is to put opengl32.dll in the Blender folder (yes it will work slower) $\endgroup$ – Mr Zak Oct 23 at 20:34
0
$\begingroup$

I have problems running Blender on my Windows 10 notebook. It's an old machine, can't support OpenGL 3.3 (which, as far as I know, is required for running Blender 2.8). I believe you are facing the same issue, VirtualBox can't run OpenGL 3.3, you'll need to run Blender on real hardware - that is, if your PC is at least newer than mine. I would also give you a suggestion, on Win 10 I can't run Blender 2.8, but it runs quite well on my machine when I use Linux - it might be worth a shot.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.