0
$\begingroup$

I've searched around the forums here and found multiple solutions for this problem, however they appear to be unique to those individuals. Their solutions do not work with this particular scenario.

I'm trying to bake multiple materials (nodes), with Cycles Render, into one UV Unwrapped Map. I've followed several tutorials on the process as well, none of them seem to change the outcome. The end product seems to be only one material, no matter how I select the material, the UV Map, or whatever, it'll always bake the Connector Material only. I cant get the other material to show up in the final render.

The Blender File: Located Here

enter image description here

After Render: enter image description here

$\endgroup$
  • $\begingroup$ Right, the Blend file doesn't contain what I've baked, because its incorrect as far as I'm concerned. I need all materials on one baked material image, so I can export it and the object into Unity. $\endgroup$ – Tiger DarkClaw Dec 28 '18 at 5:13
0
$\begingroup$

I tried to bake with basic materials and it worked fine. you should select same image texture data block in every material node. And also we bake normals and diffuse etc separately rather than combined.

->create a new blank image in uv editor and name it (say bake.png).

-> in node editor for any material: shift+A-> image texture-> browse the created image (which is blank right now). enter image description here -> Now copy the image texture node (by cltr+c) go to another material and paste in node editor (by cltr+v) do this to every material you want to bake.

-> make sure you selected right image texture node (bake.png) in every material. Because if you select other image texture node data will be baked into that image. -> bake type to diffuse or combined or normals and hit bake, after baked, save image as combined.png you may need to turn off indirect lighting in bake panel. enter image description here

$\endgroup$
  • $\begingroup$ I'm not sure I follow. What do you mean? $\endgroup$ – Tiger DarkClaw Dec 28 '18 at 5:56
  • $\begingroup$ @Leander, he edited his original post. Thank you though. $\endgroup$ – Tiger DarkClaw Dec 28 '18 at 14:54
  • $\begingroup$ @Feenix, thank you, that clears it up, I would of never added an unattached node within the material Node. I appreciate the steps, that did clear it up. Thank you so much for the time. Indirect certainly sped up render times, and it looks fantastic too. Thanks for that pro tip. $\endgroup$ – Tiger DarkClaw Dec 28 '18 at 14:54

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.