0
$\begingroup$

When I open Blender through terminal it has no error messages, however when I open settings I am greeted by this message.

Screenshot

I am using an AMD Radeon R9 390X graphics card with the amdgpu driver. I know that my GPU is supported.

Is there anything that I can do?

$\endgroup$
1
$\begingroup$

You might need to install the proprietary AMDGPU-PRO drivers, or at least the OpenCL part of it. The quick fix is to install opencl-amd from AUR:

git clone https://aur.archlinux.org/opencl-amd.git
cd opencl-amd
makepkg -s
sudo pacman -U opencl-amd-*-x86_64.pkg.tar.xz

(You might have to downgrade libdrm for opencl-amd to work, see here.)

Note that Arch Linux is not officially supported by AMDGPU-PRO.

Resources

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.