-1
$\begingroup$

Ubuntu 18.10 can run Blender 2.79;
Ubuntu 18.10 can't run Blender 2.80 Beta; (why?)
But...
VirtualBox(Ubuntu 18.10) can run Blender 2.80 Beta; (why?)

====== System info ======

root@tom-laptop:/# uname -a
Linux tom-laptop 4.18.0-10-generic #11-Ubuntu SMP Thu Oct 11 15:13:55 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

root@tom-laptop:/# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.10
Release:    18.10
Codename:   cosmic

root@tom-laptop:/# lspci |grep 'VGA'
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

root@tom-laptop:/# glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 965GM 
OpenGL version string: 2.1 Mesa 18.2.2
OpenGL shading language version string: 1.20
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 18.2.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:

sudo dmidecode -t memory
Size: 8GB; Type: DDR2




====== terminal run blender2.8 ======

root@tom-laptop:/home/tom/Tool/blender-2.801211# ./blender

Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Received X11 Error:
error code: 167
request code: 152
minor code: 34
error text: GLXBadFBConfig
Writing: /tmp/blender.crash.txt
段错误 (核心已转储)
root@tom-laptop:/home/tom/Tool/blender-2.801211#

------ vi /tmp/blender.crash.txt ------
# Blender 2.80 (sub 36), Commit date: 2018-12-10 23:13, Hash a49fdbcc674

# backtrace
./blender(BLI_system_backtrace+0x1d) [0x1b87c1d]
./blender() [0x1152f09]
/lib/x86_64-linux-gnu/libc.so.6(+0x41100) [0x7f5883e5e100]
./blender(wm_window_ghostwindows_ensure+0x3fc) [0x11790ac]
./blender(WM_check+0x4a) [0x115355a]
./blender(wm_homefile_read+0x2dc) [0x116060c]
./blender(WM_init+0x138) [0x11640a8]
./blender(main+0x28c) [0x10b951c]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xeb) [0x7f5883e4109b]
./blender(_start+0x2a) [0x114f9ea]

====================

======================

===========================

But...
VirtualBox(Ubuntu18.10) can run blender2.80bate; (why?)
=======================
virtualbox-5.2_5.2.22-126460_Ubuntu_bionic_amd64

root@tom-VirtualBox:/media# lsb_release -a
Description:    Ubuntu 18.04.1 LTS
Release:    18.04   Codename:   bionic

root@tom-VirtualBox:/media# cat /proc/version
Linux version 4.15.0-29-generic (buildd@lgw01-amd64-057) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018

root@tom-VirtualBox:/media# uname -a
Linux tom-VirtualBox 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

root@tom-VirtualBox:/media# lscpu
Model name: Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz

root@tom-VirtualBox:/# lspci |grep 'VGA'
00:02.0 VGA compatible controller: VMware SVGA II Adapter

=========================
$\endgroup$
  • $\begingroup$ Hello Ted, the right place for crashes/bugs is the bug tracker. Please be mindful of spelling when you make a post: I'm not saying you must be an English native speaker, but at least get the name of the software right :D It's Blender 2.80 Beta, not "Blunder 2.80 bate" $\endgroup$ – Nicola Sap Dec 27 '18 at 7:17
  • $\begingroup$ Make sure you have updated to the latest driver for your graphics card. 2.8 requires openGL.. 3.2 or 3.3 or greater to be supported by your card. (Must do given the graphics driver used by virtual box works) (btw recommend sticking with LTS versions of ubuntu) $\endgroup$ – batFINGER Dec 27 '18 at 12:12
0
$\begingroup$

It seems that's all about the OpenGL. AFAIK, 2.79 needs gl 3.2 to run its GUI. You have v2.1. So, I can bet, this is the OpenGL issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.